linux中jboss无法启动原因如何排查并解决
Admin 2022-08-17 群英技术资讯 1726 次浏览
今天这篇给大家分享的知识是“linux中jboss无法启动原因如何排查并解决”,小编觉得挺不错的,对大家学习或是工作可能会有所帮助,对此分享发大家做个参考,希望这篇“linux中jboss无法启动原因如何排查并解决”文章能帮助大家解决问题。解决方法:1、利用“hostname hy”命令,将hostname改为hy;2、修改“/etc/hosts”文件或“/etc/sysconfig/network”文件修改hostname,并利用“service network restart”重启网络服务即可。

本教程操作环境:linux7.3系统、Dell G3电脑。
一、问题描述
Linux服务器重启后,发现原本能正常启动的Jboss实例和ActiveMQ实例都无法正常启动了,
Jboss报错如下:
java.net.MalformedURLException: Local host name unknown: java.net.UnknowstException: hy-192.168.1.103: hy-192.168.1.103: unknown error
ActiveMQ报错如下:
Invocation of init method failed; nested exception is java.net.URISyntaxException: Illegal character in hostname at index 27: ws://hy-192.168.1.103:61614?maximumConnections=1000&wireFormat.maxFrameSize=104857600
二、问题排查
确认Jboss和ActiveMQ的启动脚本、配置信息均未修改过,之前是可以正常启动的,只是Linux服务器重启过后,发现两个组件无法启动了,查看原因都是跟本服务器的host name 相关的。
Linux服务器跟hostname相关的地方有三处:/etc/hosts、/etc/sysconfig/network、hostname命令。
1、查看/etc/hosts如下:
[admin@localhost Desktop]$ more /etc/hosts 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6 192.168.1.103 hy
2、查看/etc/sysconfig/network如下:
[admin@localhost Desktop]$ more /etc/sysconfig/network NETWORKING=yes HOSTNAME=hy
3、hostname命令查看host name如下:
[admin@localhost Desktop]$ hostname hy-192.168.1.103
三处查看发现hostname与hosts、network配置信息不一致,根据实例的报错期望的hostname应该是hy这种,而不是hy-192.168.1.103这样带IP的。
三、问题修改
1、将hostname改为hy即可,命令如下:
hostname hy
改完后记得用hostname命令或uname -a命令查看修改是否生效。
2、如果是修改/etc/hosts文件或/etc/sysconfig/network文件,
最后一定不要忘记让修改过的东西生效,生效命令:
service network restart
其实就是重启网络服务。
免责声明:本站发布的内容(图片、视频和文字)以原创、转载和分享为主,文章观点不代表本网站立场,如果涉及侵权请联系站长邮箱:mmqy2019@163.com进行举报,并提供相关证据,查实之后,将立刻删除涉嫌侵权内容。
猜你喜欢
linux系统卡顿是怎么回事,如何找原因?一些朋友可能会遇到这方面的问题,对此在下文小编向大家来讲解一下,内容详细,易于理解,希望大家阅读完这篇能有收获哦,有需要的朋友就往下看吧!
linux能获取本地ip地址。方法:1、利用“ifconfig -a”命令,该命令用于显示或者设置网络设备信息;2、利用“ip address”命令,语法为“ip address | grep eth0 | awk '{print$2}'”;3、利用“hostname -I”命令,该命令可以获取具体的网卡信息。
linux中finger找不到的解决方法:1、将镜像文件加载到Linux光驱,并将光驱挂载到Linux系统上;2、利用“ls | grep finger”命令定位finger软件包;3、利用“rpm -ivh 完整的rpm包名”命令安装finger即可。
linux下的cp命令有什么功能?在实际的使用中,我们常会遇到复制文件的需求,而cp命令的功能就是可以用来复制文件和目录,另外还可以实现复制整个目录,那么cp命令如何使用呢?接下来我们具体了解看看。
小编今天给大家来说说看“linux下给网站目录添加sgid权限有哪些好处”的内容,本文具有一定的参考价值,如果你刚好需要这方面的内容,就请看看小编为大家准备的资料吧!
成为群英会员,开启智能安全云计算之旅
立即注册关注或联系群英网络
7x24小时售前:400-678-4567
7x24小时售后:0668-2555666
24小时QQ客服
群英微信公众号
CNNIC域名投诉举报处理平台
服务电话:010-58813000
服务邮箱:service@cnnic.cn
投诉与建议:0668-2555555
Copyright © QY Network Company Ltd. All Rights Reserved. 2003-2020 群英 版权所有
增值电信经营许可证 : B1.B2-20140078 ICP核准(ICP备案)粤ICP备09006778号 域名注册商资质 粤 D3.1-20240008