MongoDB启动报错28663是什么原因?如何解决?
Admin 2021-05-06 群英技术资讯 1498 次浏览
很多新手在学习mongoDB的时候会遇到启动报错28663的问题,但是又不知道如何解决,其实这是引擎导致的问题,下面小编就给大家分享一下解决方法,有需要的朋友可以参考一下。
启动MongoDB服务
进入安装目录的bin目录,在CMD中执行: mongod --dbpath=数据存放目录这里可以在任何位置建立一个文件夹,有可能在安装过程中出现问题,比如提示 28663错误,则是引擎不适合MONGODB,需要在启动的时加上 -storageEngine=mmapv1
28663 Cannot start server. The default storage engine 'wiredTiger' is not available
刚开始接触MongoDB,结果一开始就在安装数据库的这个步骤遇到了服务无法启动的问题。根据错误提示得知是由于当前数据库引擎不支持32系统所导致的,解决这个问题很简单,只要切换下MongoDB的默认数据库引擎即可,当然最好是升级到64位系统,毕竟没有2GB的限制而且新引擎的性能也有很大的提升。
一开始是使用 mongod --dbpath 命令进行安装:

当时安装的MongoDB版本是3.2.1,此版本的默认引擎是wiredTiger,正好32位系统不支持此引擎,所以会抛出如下的错误:
2020-02-01T17:04:08.333+0800 I STORAGE [initandlisten] exception in initAndListen: 28663 Cannot start server. The default storage engine 'wiredTiger' is not available with this build of mongod.Please specify a different storage engine explicitly, e.g. --storageEngine=mmapv1., terminating

仔细看下错误提示,错误提示很清晰的说了问题产生的原因和解决方法,我们只要在安装MonogoDB的命令后面加一个参数--storageEngine=mmapv1,将wiredTiger引擎切换成mmapv1引擎,安装即可成功!!!

免责声明:本站发布的内容(图片、视频和文字)以原创、转载和分享为主,文章观点不代表本网站立场,如果涉及侵权请联系站长邮箱:mmqy2019@163.com进行举报,并提供相关证据,查实之后,将立刻删除涉嫌侵权内容。
猜你喜欢
在本章中,我们将学习如何从表中选择数据。下文的讲解详细,步骤过程清晰,对大家进一步学习和理解相关知识有一定的帮助。有这方面学习需要的朋友就继续往下看吧!
MySQL和MariaDB区别是什么?这篇文章主要给大家介绍MySQL数据库和MariaDB数据库的区别,下面会从两者的功能以及性能等方面进行对比,感兴趣的朋友可以继续往下看。
这篇我们来简单的了解一下MariaDB事务的相关内容,文中介绍了MariaDB事务处理及事务的结构,对大家学习和理解MariaDB事务有一定的帮助,感兴趣的朋友接下来一起跟随小编看看吧。
在本章中,我们将学习如何在表中插入数据。小编觉得挺不错的,对大家学习或是工作可能会有所帮助,对此分享发大家做个参考,希望这篇文章能帮助大家解决问题。
在MariaDB数据库中,使用SELECT语句和LIMIT子句从表中检索一个或多个记录。
成为群英会员,开启智能安全云计算之旅
立即注册关注或联系群英网络
7x24小时售前:400-678-4567
7x24小时售后:0668-2555666
24小时QQ客服
群英微信公众号
CNNIC域名投诉举报处理平台
服务电话:010-58813000
服务邮箱:service@cnnic.cn
投诉与建议:0668-2555555
Copyright © QY Network Company Ltd. All Rights Reserved. 2003-2020 群英 版权所有
增值电信经营许可证 : B1.B2-20140078 ICP核准(ICP备案)粤ICP备09006778号 域名注册商资质 粤 D3.1-20240008