Thinkphp5中修改nginx配置要注意什么,404错误怎样解决
Admin 2022-06-13 群英技术资讯 1493 次浏览
这篇文章主要介绍了Thinkphp5中修改nginx配置要注意什么,404错误怎样解决相关知识,内容详细易懂,操作简单快捷,具有一定借鉴价值,相信大家阅读完这篇Thinkphp5中修改nginx配置要注意什么,404错误怎样解决文章都会有所收获,下面我们一起来看看吧。第一:修改nginx配置
注意:所有配置都是基于lnmp1.4的一键安装环境的
根据自己的nginx配置,找到正确的fastcgi.conf,修改fastcgi_param参数
将默认的路径修改至自己的项目根目录的上一级,注意是上级!!!
3、lnmp nginx reload
lnmp nginx restart
第二:执行service nginx restart命令重启nginx,发现网页报404错误,需要配置一下伪静态可以在/usr/local/nginx/conf/www.tp5.com.conf(根据实际情况而定)添加:
location ~ .*\.(php|php5)?$
{
#fastcgi_pass unix:/tmp/php-cgi.sock;
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
include fastcgi.conf;
}
location / {
if (!-e $request_filename) {
rewrite ^(.*)$ /index.php?s=/$1 last;
break;
}
}
代码放在server{} 内
第三:
php错误scandir() has been disabled for security reasons
原因:
php.ini里禁用了scandir()方法
解决:
编辑php.ini文件
disable_functions = scandir,passthru,exec,system,chroot,chgrp,chown,shell_exec,proc_open,proc_get_status,ini_alter,ini_alter,ini_restore,dl,pfsockopen,openlog,syslog,readlink,symlink,popepassthru,stream_socket_server,fsocket,fsockopen
去掉scandir保存并重起php-fpm即可。
php.ini 的位置:/usr/local/php/etc/php.ini
最后执行/etc/init.d/php-fpm restart重启下
免责声明:本站发布的内容(图片、视频和文字)以原创、转载和分享为主,文章观点不代表本网站立场,如果涉及侵权请联系站长邮箱:mmqy2019@163.com进行举报,并提供相关证据,查实之后,将立刻删除涉嫌侵权内容。
猜你喜欢
这篇文章主要为大家详细介绍了PHP如何实现导入大量CSV数据功能,文中的示例代码讲解详细,对我们学习PHP有一定帮助,需要的可以参考一下
PHP优化的目的是花最少的代价换来最快的运行速度与最容易维护的代码。本文给大家提供全面的优化技巧。1、echo比print快。2、使用echo的多重参数代替字符串...
区别:1、Laravel在提交表单时需要在表单中加入“@csrf”来防止跨域攻击,而tp不需要添加;2、Laravel使用“Db::操作(‘原生sql’)”进行原生查询,而tp使用“Db::query(‘原生sql’)”进行原生查询。
sqlite在php中是默认安装的本地小型化数据库,类似于xml的小型数据库,但sqlite功能更强。
workerman中定时器不生效的原因是:定时器不能在【runAll】方法执行前运行,此方法执行前运行的代码全部属于主进程,主进程不能有业务代码,主进程的业务代码会被子进程继承。解决方法是:在【onWorkerStart】中运行定时器即可。
成为群英会员,开启智能安全云计算之旅
立即注册关注或联系群英网络
7x24小时售前:400-678-4567
7x24小时售后:0668-2555666
24小时QQ客服
群英微信公众号
CNNIC域名投诉举报处理平台
服务电话:010-58813000
服务邮箱:service@cnnic.cn
投诉与建议:0668-2555555
Copyright © QY Network Company Ltd. All Rights Reserved. 2003-2020 群英 版权所有
增值电信经营许可证 : B1.B2-20140078 ICP核准(ICP备案)粤ICP备09006778号 域名注册商资质 粤 D3.1-20240008